Skip to end of metadata
Go to start of metadata

La version 1.4 de ORI-OAI est téléchargeable. La documentation d'installation est disponible dans la partie "INSTALLATION" du site.

Cette version prend en compte un grand nombre de remarques des utilisateurs de la version 1.1. Elle propose également de nouvelles fonctionnalités :

  • Support des formats LOMFR et Sup-LOMFR (édition et recherche).
  • Migration des fiches de métadonnées saisies en 1.0 ou 1.1 du LOM vers LOMFR ou Sup-LOMFR.
  • Mise en place d'un web service pour initier un workflow de saisie depuis une autre application.
  • Compatibilité Firefox 3 de l'éditeur de métadonnées.
  • Le gestionnaire de workflow supporte l'authentification/identification shibboleth
  • Refonte de la gestion du transfert des vocabulaires entre les modules. Les versions précédentes de ORI-OAI étaient fortement ralenties lors de l'utilisation de l'éditeur de métadonnées ou du moteur de recherche à cause de la génération des vocabulaires dynamiques. Pour palier à ce problème, les vocabulaires sont générés dès le démarrage des services et la dernière version valide des vocabulaires est renvoyée à la demande sans attendre la nouvelle génération.
  • Indexation plein texte des fichiers référencés dans les fiches de métadonnées. Cette indexation se fait à intervalles réguliers (la nuit par exemple) de manière asynchrone. Il est donc maintenant possible de croiser la recherche sur le plein texte des documents avec la recherche sur les métadonnées.
  • Chargement des vocabulaires du démarrage du moteur de recherche pour une optimisation du temps de réponse.
  • Optimisation du temps de chargement du module en mode portlet.
  • Ajout de possibilités de recherche avancée (recherche "experte", cases à cocher, boutons radio, choix multiples, affichage de champs sous certaines conditions, etc.).
  • Génération d'URL "propres" pour l'affichage des fiches de métadonnées et des documents. Les documents sont affichés dans le navigateur avec l'URL du moteur de recherche. Un bandeau montre à l'utilisateur l'URL réélle du document. Ce mécanisme permet à l'utilisateur de mettre dans ses favoris l'URL du moteur de recherche pointant sur ce document à la place de l'URL du document. Cela permet de toujours garder le bon lien, même en cas de changement d'URL du document.
  • Ajout d'une compatibilité avec les gestionnaires de statistiques Piwik et Google analytics.
  • Possibilité d'utiliser des interfaces dynamiques (AJAX) pour l'affichage des fiches de métadonnées ou pour affiner les recherches.
  • Modification de la gestion des sets OAI dans le moissonneur. Il est maintenant possible de moissonner certaines fiches en croisant ou en associant différents sets. Exemple: ne moissonner que les fiches de métadonnées LOM qui apparaissent à la fois dans le set "Informatique" et dans le set "Mathématiques".
  • Le module ori-oai-repository passe la validation openarchives.org. Exemple: UNIT est référencée sur le site http://www.openarchives.org/Register/BrowseSites
  • Dans le module ori-oai-repository, il est possible de filtrer l'exposition des fiches sur n'importe quel champ de métadonnées. Exemple: n'exposer que les fiches où "lom:rights" correspond à "gratuit".
  • Possibilité de générer autant de sets que l'on souhaite en se reposant sur n'importe quelle métadonnée associée au vocabulaire souhaité. Exemple: un set thématique se reposant sur le vocabulaire de la Dewey et un autre set sur le vocabulaire gratuit/payant et la métadonnée lom:rights).
  • etc.

Stockage des documents

Icon

Contrairement aux annonces qui avaient été faites, cette version n'intègre pas encore le nouveau système de stockage ESUP-ECM basé sur Nuxeo. En effet, toute l'équipe de développement s'est concentrée pour sortir une version 1.4 intégrant un maximum de corrections de bugs et de nouvelles fonctionnalités dans une première étape.

La version 1.5 annoncée se découpe donc en deux phases:

  1. une nouvelle version des modules existants de ORI-OAI en version 1.4
  2. la sortie du module ESUP-ECM basé sur Nuxeo pour apporter une solution de stockage

Ces deux étapes formeront donc la version 1.5 de ORI-OAI. (ORI-OAI version 1.5) = (ORI-OAI version 1.4) + ESUP-ECM

N'attendez pas avant de migrer vers la version 1.5

Icon

Il est très important de noter que les modules qui viennent de sortir en 1.4 n'évolueront pas lors de la sortie de la 1.5. Vous pouvez donc dès à présent installer cette nouvelle version ou migrer vers la version 1.4.

Lors de la sortie du module de stockage ESUP-ECM, la version officielle de ORI-OAI sera donc la 1.5. Mais les modules proposés aujourd'hui seront les mêmes qu'en 1.4. ESUP-ECM viendra simplement se connecter sur votre version 1.4 existante.

N'attendez pas, vous pouvez dès à présent passer à la version 1.4 ! La version 1.5 ne sera que l'ajout du module ESUP-ECM à l'existant. Vous pouvez donc gagner du temps en installant,en configurant et en personnalisant cette version 1.4 pour vos besoins. Vos configurations ne changeront pas avec la sortie de la 1.5.

La prochaine étape est donc la sortie du module de stockage qui viendra se brancher sur la version 1.4 actuelle des modules ORI-OAI.

Toute l'équipe des développeurs est actuellement en train de travailler sur ce nouveau module afin de proposer une solution de stockage fiable répondant aux besoins des utilisateurs le plus rapidement possible.

  • No labels